SurveySparrow - Delayed Response Sync – Incident details

Delayed Response Sync

Resolved
Degraded performance
Started about 1 month agoLasted 5 days

Affected

US EAST (NORTH VIRGINIA)

Operational from 9:00 AM to 9:34 AM

Collect responses

Operational from 9:00 AM to 9:34 AM

EU CENTRAL (FRANKFURT)

Operational from 9:00 AM to 9:34 AM

Collect responses

Operational from 9:00 AM to 9:34 AM

EU WEST (LONDON)

Operational from 9:00 AM to 9:34 AM

Collect responses

Operational from 9:00 AM to 9:34 AM

Updates
  • Update
    Update

    The sync delay that occurred between June 20 to June 25 has now been fully resolved.

    Submissions created after June 25 were not affected.

    While the root cause was fixed on June 25, background jobs related to submissions during the affected window were processed with a delay.

    All such jobs have now been successfully completed, and the issue has been fully resolved

  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We identified a delay in syncing responses from the secondary database to the primary database.

    This issue impacted only surveys with partial submissions that were shared using the first-question embed.